Kerentanan remote code execution (rce) telah ditemukan di perangkat lunak jaringan Samba yang memungkinkan penyerang jarak jauh mengendalikan mesin Linux dan Unix. Samba adalah perangkat lunak open-source yang berjalan pada sebagian besar sistem operasi yang ada saat ini, termasuk Windows, Linux, UNIX, IBM System 390, dan OpenVMS. Samba memungkinkan sistem operasi non-Windows, seperti GNU/Linux atau Mac OS X, untuk berbagi folder bersama jaringan, file, dan printer dengan sistem operasi Windows.


Kerentanan eksekusi kode jarak jauh yang baru ditemukan (CVE-2017-7494) mempengaruhi semua versi yang lebih baru dari Samba 3.5.0 yang dirilis pada tanggal 1 Maret 2010.

    "Semua versi Samba dari 3.5.0 dan seterusnya rentan terhadap kerentanan eksekusi kode jarak jauh, yang memungkinkan klien nakal mengunggah shared library dan kemudian menyebabkan server memuat dan menjalankannya," seperti diinformasikan oleh Samba.

Menurut Shodan computer search engine, lebih dari 485.000 komputer berkemampuan Samba terkena port 445 di Internet, dan menurut para peneliti Rapid7, lebih dari 104.000 titik yang terpapar di internet menjalankan versi Samba yang rentan terhadap serangan, 92.000 diantaranya menjalankan Samba unsupported versions.

Karena Samba adalah protokol SMB yang diterapkan pada sistem Linux dan UNIX, maka beberapa ahli mengatakan bahwa ini adalah "versi Linux dari EternalBlue," yang digunakan oleh ransomware WannaCry, bisa dikatakan sebagai SambaCry :) Jaringan yang menggunakan perangkat penyimpanan seperti jaringan (NAS) juga rentan terhadap serangan ini. Hanya satu baris kode yang diperlukan untuk mengeksekusi kode berbahaya pada sistem yang terpengaruh.

    Simple.create_pipe ("/path/to/target.so")

Namun, pemanfaatan Samba telah di porting ke Metasploit, sebuah kerangka pengujian penetrasi, yang memungkinkan periset serta hacker memanfaatkan kelemahan ini dengan mudah. Samba telah menambal masalah ini di versi Samba versi terbaru Samba 4.6.4 / 4.5.10 / 4.4.14, dan mendesak pengguna untuk segera menggunakan versi Samba versi terbaru sesegera mungkin. Tapi jika Anda tidak bisa mengupgrade ke Samba versi terbaru segera, Anda bisa mengatasi kerentanan tersebut dengan menambahkan baris berikut ke file konfigurasi Samba Anda smb.conf:

    nt pipe support = no

Setelah ditambahkan, restart network's SMB daemon (smbd) dan selesai. Sementara vendor distribusi Linux, termasuk Red Hat dan Ubuntu, telah merilis versi patch untuk penggunanya, risiko yang lebih besar adalah konsumen perangkat NAS yang mungkin tidak akan diperbarui dengan cepat.
 
Top